
 

 

 

 

Studuino:bit Online 

Support Guide 

 

 

Published 2021/09/30 

 

 

The information in this manual is subject to revision at any time. 



 

 

 

 

Version History 

 

  

Date Revised Revised Contents 

9/30/2021 First version 



 

 

 

 

Index 

1. Getting Started ...................................................................................................... 1 

2. System Requirements .......................................................................................... 1 

2.1. Windows .................................................................................................................. 1 

2.2. Chromebook ............................................................................................................ 1 

2.3. Mac OS X ................................................................................................................. 1 

3. Connecting ............................................................................................................. 2 

3.1. USB ........................................................................................................................... 2 

3.2. Bluetooth ................................................................................................................. 4 

4. Using the Software ............................................................................................... 7 

4.1. Transferring a Program (Robot Mode Only) ........................................................ 7 

4.1.1. USB ................................................................................................................. 7 

4.1.2. Bluetooth ....................................................................................................... 9 

4.2. Saving and Loading a Project ............................................................................. 12 

4.3. Loading a Downloaded Project ........................................................................... 12 

4.3.1. For Windows ................................................................................................ 12 

4.3.2. For Chromebook ......................................................................................... 13 

4.3.3. For Mac OS X ............................................................................................... 14 

4.4. Updating Firmware ............................................................................................... 15 

4.5. Switching Between Robot and Character Mode ............................................... 17 

5. Troubleshooting ................................................................................................... 18 

6. Contact Us ............................................................................................................ 22 



 

1 

 

1. Getting Started 

The Studuino:bit Online web application covered in this manual can be accessed 

using the URL below. 

Use the in-software tutorials to learn how to make best use of the software. 

For wired USB users: https://app.artec-kk.co.jp/studuinobit/usb/ 

For wireless Bluetooth users: https://app.artec-kk.co.jp/studuinobit/bt/ 

 

2. System Requirements 

The web application requires an active Internet connection and Chrome version 89 

or later. 

2.1. Windows 

OS 

Windows10 

Hardware 

For wired USB connection: Device equipped with USB port 

For wireless Bluetooth connection: Device with Bluetooth 4.0 

 

2.2. Chromebook 

OS 

ChromeOS 

Hardware 

For wired USB connection: Device equipped with USB port 

For wireless Bluetooth connection: Device with Bluetooth 4.0 

 

2.3. Mac OS X 

OS 

Mac OS X 10.14 or later 

Hardware 

Hardware with minimum OS requirements. 

https://app.artec-kk.co.jp/studuinobit/usb/
https://app.artec-kk.co.jp/studuinobit/bt/
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3. Connecting 

3.1. USB 

① Connect your Core Unit to the PC using a USB cable. 

 

② Visit the URL below using Chrome version 89 or later. 

★ Application will not work with Safari, Edge, IE, Firefox, or other browsers. 

 

For wired USB users: https://app.artec-kk.co.jp/studuinobit/usb/ 

③ Now choose Connect from the Edit Menu. 

 

④ Choose STM32 and click Connect. 

 

https://app.artec-kk.co.jp/studuinobit/usb/
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⑤ Once connected, you’ll see the Sensor Board which will show a live update of the 

Core Unit’s sensors. Disconnecting the USB cable will interrupt the connection 

and the values will no longer update. 

 

⑥ If you want to close the connection, choose the Edit menu before selecting 

Disconnect. If the connection has been interrupted due to an unplugged USB 

cable, choose Disconnect. 
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3.2. Bluetooth 

① Plug the Battery Box into the BATT port on your Core Unit and turn it on. 

 

 

② Visit the URL below using Chrome version 89 or later. 

★ Application will not work with Safari, Edge, IE, Firefox, or other browsers. 

For wireless Bluetooth users: https://app.artec-kk.co.jp/studuinobit/bt/ 

 

③ Hold down the B button as you press the Reset button once. 

 

 

④ Keep holding the B button until you see a colorful LED pattern appear on the 

display. 

 

https://app.artec-kk.co.jp/studuinobit/bt/
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⑤ Now choose Connect from the Edit Menu. 

 

⑥ You’ll see a list of available Core Units with an LED pattern next to each one. 

Choose Studuino:bit XXXX (where XXXX is a four-digit number) and click Pair. 

 

⑦ Make sure that the pattern on the screen matches the pattern on your Core 

Unit’s LED display before clicking Connect. If the pattern doesn’t match, click 

the X at the top right to close the window. Repeat step ⑤ to connect again and 

choose a different device from the one in step ⑥. 

 

Check here to skip 

step ⑦ next time 

you connect 
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⑧ Once connected you’ll see the Sensor Board which will show a live update of the 

Core Unit’s sensors. 

 

⑨ If you want to close the connection, choose the Edit menu before selecting 

Disconnect. If the connection has been interrupted, choose Disconnect. 
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4. Using the Software 

4.1. Transferring a Program (Robot Mode Only) 

4.1.1. USB 

① Choose Transfer from the Edit menu. 

 

② Choose STM32 and click Connect. 

 

③ Choose a destination slot to transfer the program to. You can also change the 

name of the program here. 
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④ The blue LED you see below will light up once the transfer starts and turn off to 

indicate that the transfer is successful. 

 

 

⑤ If you see a white LED or the blue LED does not turn off, the transfer has failed. 

Press the Reset button and try transferring again. 
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4.1.2. Bluetooth 

① Hold down the B button as you press the Reset button once. 

 

② Keep holding the B button until you see a colorful LED pattern appear on the 

display. 

 

③ Choose Transfer from the Edit menu. 
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④ You’ll see a list of available Core Units with an LED pattern next to each one. 

Choose Studuino:bit XXXX (where XXXX is a four-digit number) and click 

Pair. 

 

 

⑤ Make sure that the pattern on the screen matches the pattern on your Core 

Unit’s LED display before clicking Connect. 

If the pattern doesn’t match, click the X at the top right to close the window. 

Repeat step ③ to connect again and choose a different device from the one in 

step ④. 

 

  

Check here to skip 

step ⑤ next time 

you connect 
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⑥ Choose a destination slot to transfer the program to. You can also change the 

name of the program here. 

 

 

⑦ The blue LED you see below will light up once the transfer starts and turn off to 

indicate that the transfer is successful. 

 

 

⑧ If you see a white LED or the blue LED does not turn off, the transfer has failed. 

Press the Reset button and try transferring again. 
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4.2. Saving and Loading a Project 

The File menu is where you can save and load projects which you’ve made. 

If you want to save a project, choose the File menu and select Save to your 

computer. 

If you want to load a project which has been saved previously, choose the File menu 

and select Load from your computer to choose from a list of files. 

 

 

4.3. Loading a Downloaded Project 

4.3.1. For Windows 

Start by downloading a program file from the ArtecRobo 2.0 website. 

If the file is in a .zip archive, extract the file first. Right click the zip file icon and 

choose Extract All... from the menu. You’ll see the Extract Compressed (Zipped) 

Folders dialog box. Follow the steps to extract the file. If you’re using another type 

of extraction software, use that software to extract the file. 

You can load the extracted .sbd file by choosing the File menu and selecting Load 

from your computer. 
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4.3.2. For Chromebook 

Start by downloading a program file from the ArtecRobo 2.0 website. 

● For .sbd Files 

You can load the extracted .sbd file by choosing the File menu and selecting Load 

from your computer. 

 

 

● For .zip Files 

Open the Files app on Chromebook and tap the downloaded .zip file to open it and 

show the .sbd program file. 

 

 

Drag and drop the .sbd file to My Files or a location of your choice in order to copy 

it. 
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You can load the .sbd file by choosing the File menu and selecting Load from your 

computer. 

 

 

 

4.3.3. For Mac OS X 

Start by downloading a program file from the ArtecRobo 2.0 website. 

If the file is in a .zip archive, extract the file first. Double click the .zip file to extract 

the .sbd program file. 

You can load the extracted .sbd file by choosing the File menu and selecting Load 

from your computer. 
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4.4. Updating Firmware 

You’ll need the update the firmware of your Core Unit every time the Studuibo:bit 

Software updates to a new version. When you update your software, you can update 

your firmware either by using the Help menu on your computer or when prompted 

to do so while using the software on a tablet. 

★ When updating firmware your tablet will connect to the Core Unit’s wireless 

access point. 

Please be aware that you won’t be able to update the firmware if your device has 

restrictions on which access points it can connect to. 

 

① Choose the Help menu and select Firmware update. 

 

 

② A new page will open which will guide you along in updating your firmware. 

③ Check whether the top right LED has lit up in green. 

 

④ The Core Unit will connect to the PC as a wireless access point. 

The PC Wi-Fi settings screen will open to connect to the Core Unit. 

Type 0123456789 into the password box. 

 

⑤ Click the Update button to update the firmware.  
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⑥ The firmware update process will begin. The LEDs in the display will light up in 

white in order. 

 

⑦ The update is complete once every LED has turned on and the display goes dark. 

The firmware update screen will close once the update is complete. 
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4.5. Switching Between Robot and Character Mode 

You can switch between modes by choosing the Edit menu and selecting Switch to 

the character mode or Switch to the robot mode. 

 

● Robot Mode  

Robot mode allows you to make programs which control a robot and transfer the 

programs to your Core Unit. You can also convert any programs you make in this 

mode into the Python programming language. 

 

● Character Mode 

Character mode allows you to make programs using sprites and animate those 

sprites on the screen. 
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5. Troubleshooting 

Follow along below to troubleshoot any issues you may have when using this 

software. If you’re still having trouble or can’t find your issue on the above page, feel 

free to contact us directly using the information in Contact Us on page 22. 

Issue Solution 

The parts I’ve bought 

are missing or broken. 

Please contact us using the information in Contact Us 

on page 22. 

Are there PDFs for the 

projects in my kit? 
 https://www.artec-kk.co.jp/artecrobo2/en/sample/ 

 Follow this link to download building instructions for 

each project. 

My DC Motor is clicking 

and spinning. 

Due to excessive strain, your motor has slipped to 

protect its gears. To prevent damage to the internal 

gears, the motor is designed to emit clicks and begin 

turning freely ("slip") when a excessive strain is placed 

on the axis. Should this occur, you will need to inspect 

your project and fix any strain being placed on the 

gears. The wear and tear caused by continuously 

running a motor in this condition reduces the amount of 

strain required for another slip to occur. 

The DC Motors won’t 

move. 

Your port settings may be incorrect. Check and confirm 

that your Port Settings match the ports on your 

ArtecRobo 2.0 unit and that your program is using the 

correct port numbers. 

Your batteries may be out of power. Try using fresh 

batteries. 

 

  

https://www.artec-kk.co.jp/artecrobo2/en/sample/
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Issue Solution 

The DC Motors in my project 

start to move erratically. 

Your batteries may be out of power. Once 

batteries are depleted enough, the resulting 

drop in voltage will cause DC Motors to reset 

when they attempt to move (such as rotating or 

changing direction). Try using fresh batteries. 

My Servomotors don’t rotate to 

the angles I set. 

Your batteries may be out of power. Try using 

fresh batteries. The particular Servomotor has 

an error of five or more degrees. Use the Motor 

Calibration feature in the software to correct 

this. 

My Servomotors won’t move. Your batteries may be out of power. Try using 

fresh batteries.★ Projects which use multiple 

Servomotors may not move smoothly even 

when using fresh batteries. Always remember 

to use alkaline batteries. 

My Servomotors slip and take a 

while to move again. 

In order to protect the internal gears from 

excessive strain, power to the Servomotor is 

temporarily cut. Inspect your project and fix 

any strain being placed on the gears. 

My sensors aren't reacting. Your port settings may be incorrect. Check and 

confirm that your Port Settings match the ports 

on your Core Unit and that your program is 

using the correct port numbers. 

My devices won’t 

communicate. 

Running multiple programs that use 

inter-device communications at the same time 

may cause interference. Try starting up the 

program on one Core Unit first, then starting 

the program on each subsequent Core Unit you 

intend to communicate with only when the 

previous Unit's program finished its startup. 
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Issue Solution 

I can’t transfer programs. The 

top right LED won’t light up in 

white. 

1. The transfer has failed. Press the Reset 

button and try transferring again. 

2. The transfer may fail due to outdated 

software or firmware. Download the latest 

version of the software and update your 

firmware before trying again. 

The variable, list, or custom 

block I’ve made doesn’t show 

up. 

Switch from the Code tab to another tab such 

as Python before switching back to the Code 

tab. 

My wireless blocks don’t work 

in Test Mode. 

Wireless blocks will only work when the 

program has been transferred. 

 

My Core Unit keeps 

disconnecting. 

USB 

Your USB cable or Core Unit connector may be 

damaged.  

Try replacing the USB cable. If the issue 

continues, contact us using the information in 

Contact Us on page 22. 

My Core Unit keeps 

disconnecting. 

Bluetooth 

Your batteries may be out of power. Try 

replacing them with fresh batteries. 

The top right LED lights up in 

green when I turn on the Core 

Unit. 

 

The Core Unit is connected to Wi-Fi and is 

awaiting a firmware update. 

Choose the Help menu and select Firmware 

update to finish the update. 

If you won’t wish to update the firmware, hold 

down the A button and press the Reset button 

or wait 1-2 minutes for the LED to turn off and 

the Core Unit to exit standby mode. 
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Issue Solution 

I updated by firmware 

and now get an error 

when I try to connect. 

Once the firmware is updated, press the Reset button 

on the Core Unit to check if the green LED below the 

button lights up before connecting again. 

I’ve tried multiple times 

to update my firmware 

but it doesn’t work. 

Your USB cable or Core Unit connector may be 

damaged. Try replacing the USB cable. If the issue 

continues, contact us using the information in 

Contact Us on page 22. 

I transferred my 

program but it doesn’t 

work correctly. 

Make sure the numbers in your program are correct. 

Using incorrect numbers in blocks which use 

numerical values can cause your project to work in 

unexpected ways. 

I get a message stating 

that my Core Unit’s 

firmware can’t be 

updated. 

Your firmware may be outdated or your device may 

not be able to update the device over Wi-Fi. 

Follow the URL below to download the Studuino:bit 

Software before installing it. 

https://www.artec-kk.co.jp/artecrobo2/en/software/ 

Open the software on and use the Help menu to 

update the firmware. If you’re having trouble using 

this version of the software, please contact us using 

the information in Contact Us on page 22. 

 

  

https://www.artec-kk.co.jp/artecrobo2/en/software/
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Issue Solution 

The list of available Core Units 

doesn’t appear after clicking 

Connect. 

Bluetooth 

1. The device may have not been found during 

the search. Choose Cancel and try connecting 

again. 

2. Turn Bluetooth off before turning it on again. 

I can’t find the Join a Network 

option in the Edit menu. 

Bluetooth 

Network feature is only available via a USB 

connection. 

For wired USB users: 

https://app.artec-kk.co.jp/studuinobit/usb/ 

 

 

6. Contact Us 

Artec Co., Ltd. Customer Support Desk 

E-mail: support@artec-kk.co.jp 

https://app.artec-kk.co.jp/studuinobit/usb/
mailto:support@artec-kk.co.jp

