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1. Getting Started 
This manual details how to setup the Studuino:bit software for your OS as well as 

the basics of how to use and troubleshoot the software. Use the in-software tutorials 

to learn how to make best use of the software. 

 

2. System Requirements 

2.1. Windows 
★ Only supports wired USB connection (as of September 2020).. 

OS 

Windows 7, 8.1, 10 

Hardware 

CPU: Core 2 Duo (E6700) or higher recommended 

Memory: 2GB or higher 

USB 2.0 port 

Software Setup: 3.1. For Windows (page 3) 

2.2. iPad 
★ Only supports wireless Bluetooth connection (as of September 2020).. 

OS 

iOS 11 or later 

Hardware 

iPad with minimum OS requirements 

★ iPhone and iPad mini not supported. 

Software Setup: 3.2. For  (page 13) 
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2.3. Chromebook 
OS 

ChromeOS 

Hardware 

● For wired USB connection: 

Device equipped with USB port 

● For wireless Bluetooth connection: 

2016 or later model with Studuino:bit app and Bluetooth 4.0 

★ As of September 2020, using Studuino:bit app with Bluetooth may cause 

instability. Please use a wired USB connection for maximum stability. 

★ Compatibility not guaranteed on all Chromebook devices. 

Software Setup:  

● For wired USB connection: 3.3. For Chromebook (page 26) 

● For wireless Bluetooth connection: 3.5. For Android (page 40) 

2.4. Mac OS X 
★ Only supports wired USB connection (as of September 2020). 

OS 

OS X 10.10 (64-bit) or later 

Hardware 

Device with minimum OS requirements 

Software Setup: 3.4. For Mac OS X (page 34) 

2.5. Android 
★ Only supports wireless Bluetooth connection (as of September 2020). 

OS 

Android 5.0 or later 

Hardware 

Native Android 5.0 device with screen size of 10 inches or more. 

★ Compatibility not guaranteed on all Android devices. 

Software Setup: 3.5. For Android (page 40)
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3. Setup 

3.1. For Windows 
Learn how to setup the Studuino:bit Software on the Windows operating system. 

3.1.1. Installation 
Download the installation file before installing the software. If you’re installing the 

software to a PC without an active Internet connection, download the file on a PC 

with an Internet connection before using an external memory device to transfer the 

file to the target PC. 

Administrator privileges are required to install the software. 

[1] Download the Software 

① Visit the ArtecRobo 2.0 website at https://www.artec-kk.co.jp/artecrobo2/en/: 

② Once the page opens, click Software Downloads. 

③ Click the Software Download button under Windows to download the file. 

 

[2] Installation 

① Double-click setup.exe to run it. 

② The software will automatically start once installed. 

  

https://www.artec-kk.co.jp/artecrobo2/en/
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[3] Starting the Software 

Startup method will depend on your version of Windows. Follow the steps below for 

your version: 

● Windows 7 

Click the Start menu and choose Studuino:bit Software to open the software. If 

you don’t see Studuino:bit Software in the Start menu, choose All Programs, open 

the ArTec folder, and click Studuino:bit Software to open the software. 

 

 
 

The software startup screen will allow you to choose the software mode. 

See 5. Switching Between Robot and Character Mode (page 59) to learn the 

difference between software modes. 

 
 

See 3.1.2. Installing USB Device Driver (page 7) to learn how to connect to your 

Studuino:bit Core Unit. 
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● Windows 8.1 

Once the Studuino:bit Software icon appears on the Metro screen, click it to open 

the software. 

 

The software startup screen will allow you to choose the software mode. 

See 5. Switching Between Robot and Character Mode (page 59) to learn the 

difference between software modes. 

 
See 3.1.2. Installing USB Device Driver (page 7) to learn how to connect to your 

Studuino:bit Core Unit. 
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● Windows 10 

Click the Start menu and choose Studuino:bit Software to open the software. 

 

The software startup screen will allow you to choose the software mode. 

See 5. Switching Between Robot and Character Mode (page 59) to learn the 

difference between software modes. 
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3.1.2. Installing USB Device Driver 
USB device drivers must be installed on Windows 7 and Windows 8.1 systems. 

Download the installation file before installing the software. If you’re installing the 

software to a PC without an active Internet connection, download the file on a PC 

with an Internet connection before using an external memory device to transfer the 

file to the target PC. 

Administrator privileges are required to install the software. 

[1] Download the Software 

① Visit the ArtecRobo 2.0 website at https://www.artec-kk.co.jp/artecrobo2/en/: 

② Once the page opens, click Software Downloads. 

③ Click the USB Device Driver Download button under Windows to download 

the file. 

[2] Installation 

① Unzip the studuino_bit_driver.zip file that you’ve just downloaded. 

★ Depending on your system settings, you may not see the .zip extension. 

② You will see the following file in the destination folder. 

 

 
Double click setup.bat and follow the steps to install. 

★ Depending on your system settings, you may not see the .bat extension. 

③ Once installed, connect your Core Unit to the PC using a USB cable. 

④ You should see the message Device driver software installed successfully at 

the bottom right of your screen, which indicates that the USB device driver has 

been installed. 

 

 

https://www.artec-kk.co.jp/artecrobo2/en/
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3.1.3. Connecting 
① Connect your Core Unit to the PC using a USB cable. 

 
② Now choose Connect from the Edit Menu. 

 
③ Once connected you’ll see the Sensor Board which will show a live update of the 

Core Unit’s sensors. Disconnecting the USB cable will interrupt the connection 

and the values will no longer update. 
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④ If you want to close the connection, choose the Edit menu before selecting 

Disconnect. If the connection has been interrupted due to an unplugged USB 

cable, choose Disconnect. 

 
 

 

3.1.4. Transferring a Program (Robot Mode Only) 
① Choose Transfer from the Edit menu. 

 
② Choose a destination slot to transfer the program to. You can also change the 

name of the program here. 
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③ The blue LED you see below will light up once the transfer starts and turn off to 

indicate that the transfer is successful. 

 
④ If you see a white LED or the blue LED does not turn off, the transfer has failed. 

Press the Reset button and try transferring again. 

 
 

 

3.1.5. Saving and Loading a Project 
The File menu is where you can save and load projects which you’ve made. 

If you want to save a project, choose the File menu and select Save to your 

computer. 

If you want to load a project which has been saved previously, choose the File menu 

and select Load from your computer to choose from a list of files. 
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3.1.6. Loading a Downloaded Project 
Start by downloading a program file from the ArtecRobo 2.0 website. 

If the file is in a .zip archive, extract the file first. Right click the zip file icon and 

choose Extract All... from the menu. You’ll see the Extract Compressed (Zipped) 

Folders dialog box. Follow the steps to extract the file. If you’re using another 

extraction software, use that software to extract the file. 

You can load the extracted .sbd file by choosing the File menu and selecting Load 

from your computer. 

 
 

 

3.1.7. Updating Firmware 
You’ll need the update the firmware of your Core Unit every time the Studuibo:bit 

Software updates to a new version. When you update your software, you can update 

your firmware either by using the Help menu on your computer or when prompted 

to do so while using the software on a tablet. 

 
When your Core Unit is connected via USB, choose OK to begin updating the 

firmware. 
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3.2. For iPad 
This section details how to setup the Studuino:bit Software on the iPad. 

3.2.1. Installation 
Search for Studuino:bit in the App Store and install the software. 

 
You’ll see the icon below on your iPad once the app is installed. 

 
 

 

3.2.2. Connecting 
① Plug the Battery Box into the BATT port on your Core Unit and turn it on. 
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② Now choose Connect from the Edit Menu. 

 
③ Follow the instructions on the screen and hold down the B button as you press 

the Reset button once. 

 
④ Hold down the B button until you see a colorful LED pattern appear on the 

display. 
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⑤ In the software, choose the device with the same pattern as the Core Unit’s LED 

display. 

 
⑥ Once connected you’ll see the Sensor Board which will show a live update of the 

Core Unit’s sensors. 

 
⑦ If you want to close the connection, choose the Edit menu before selecting 

Disconnect. If the connection has been interrupted, choose Disconnect. 

 

  

Connect 

Choose the Refresh button 
if you don’t see your pattern in the 
software. 
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3.2.3. Transferring a Program (Robot Mode Only) 
① Choose Transfer from the Edit menu. 

 
② Follow the instructions on the screen and hold down the B button as you press 

the Reset button once. 

 
③ Hold down the B button until you see a colorful LED pattern appear on the 

display. 
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④ In the software, choose the device with the same pattern as the Core Unit’s LED 

display. 

 
⑤ Choose a destination slot to transfer the program to. You can also change the 

name of the program here. 

 
⑥ The blue LED you see below will light up once the transfer starts and turn off to 

indicate that the transfer is successful. 

 

  

Connect 

Choose the Refresh button 
if you don’t see your pattern in the 
software. 
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⑦ If you see a white LED or the blue LED does not turn off, the transfer has failed. 

Press the Reset button and try transferring again. 

 
 

 

 

3.2.4. Saving and Loading a Project 
The File menu is where you can save and load projects which you’ve made. 

 
If you want to save a project, choose the File menu and select Save to your 

computer. 
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Type the project name and select OK to save it as a new file. 

Tap a project in the list and that name will appear in the text box. Tap OK to save 

over the existing project. 

 
If you want to load a project which has been saved previously, choose the File menu 

and select Load from your computer. Choose a project for the list before tapping 

OK. 

 

  

Name your project 

Saved projects are shown here 
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3.2.5. Loading a Downloaded Project 
Start by downloading a program file from the ArtecRobo 2.0 website. 

● For .sbd Files 

 
.sbd files are files made in the Studuino:bit Software. Choose the File menu and 

select Save to your computer. 

 
You can now open the program by choosing the File menu and selecting Load from 

your computer. 
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● For .zip Files 

Download the .zip file using Save to Files. 

 
The file will be saved to your Downloads folder, and you can check it using an app 

like File Manager. Use a decompression app to extract the downloaded .zip file. Open 

the extacted .sbd file using an app like File Manager. Read the instructions for each 

app to learn how to best use it. 

 

  

★ What you see will depend on the app you’re using. 
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Choose the File menu and select Save to your computer to save the current 

project. 

 

You can now open the file by choosing the File menu and selecting Load from your 

computer. 

 
 

 

 

3.2.6. Sharing Projects 
If you want to share a project you’ve made, choose the File menu and select Load 

from your computer. Choose a project for the list before tapping Share and 

choosing a sharing method. 
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3.2.7. Updating Firmware 
You’ll need the update the firmware of your Core Unit every time the Studuibo:bit 

Software updates to a new version. When you update your software, you can update 

your firmware either by using the Help menu on your computer or when prompted 

to do so while using the software on a tablet. 

★ When updating firmware your tablet will connect to the Core Unit’s wireless 

access point. 

Please be aware that you won’t be able to update the firmware if your device has 

restrictions on which access points it can connect to. 

 

① Plug the Battery Box into the BATT port on your Core Unit and turn it on. 

 
② Now choose Connect from the Edit Menu. 

 
③ Follow the instructions on the screen and hold down the B button as you press 

the Reset button once. 
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④ Hold down the B button until you see a colorful LED pattern appear on the 

display. 

 
⑤ In the software, choose the device with the same pattern as the Core Unit’s LED 

display. 

 
⑥ Choose the Help menu and select Firmware update. 

 
⑦ Tap OK. 

 
  

Connect 

Choose the Refresh button 
if you don’t see your pattern in the 
software. 
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⑧ Check whether the top right LED has lit up in green, then tap OK. 

 
⑨ The Core Unit will connect to the iPad as a wireless access point. 

 

⑩ The firmware update process will begin. The LEDs in the display will light up in 

white in order. 

 
⑪ The update is complete once every LED has turned on and the display goes dark. 
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3.3. For Chromebook 
This section details how to setup the Studuino:bit Software on Chromebooks. 

● For wireless Bluetooth connection go to 3.5. For Android on page 40. 

★ As of September 2020, using Studuino:bit app with Bluetooth may cause 

instability. Please use a wired USB connection for maximum stability. 

 

 
 

3.3.1. Installation 
[1] Installation 

Search for and install Artec Device Programming Software from the Chrome web 

store. 

 

 

An active Internet connection is required to start the software. 

★ Go to 3.3.2. Using Offline on page 27if you don’t have an active Internet 

connection. 

URL: 

https://chrome.google.com/webstore/detail/artec-device-link/lfnffofhlmffgdiiea

ciepapbejnloam?hl=en&authuser=0 

Artec Device Programming Software 

https://chrome.google.com/webstore/detail/artec-device-link/lfnffofhlmffgdiieaciepapbejnloam?hl=en&authuser=0
https://chrome.google.com/webstore/detail/artec-device-link/lfnffofhlmffgdiieaciepapbejnloam?hl=en&authuser=0
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You’ll see the icon below in your applications once installed. 

 
 

[2] Starting the Software 

① Open the software and you’ll see the launcher below. 

The icons below will appear in your App Launcher. Pick the Studuino:bit icon. 

 
② This will open Chrome and use your Internet connection to start the visual 

programming environment. This environment is a Scratch 3.0-based web 

application. 

 

3.3.2. Using Offline 
The following method details how to use the software without an active Internet 

connection. 

① Use the URL below to download the right file for your device and extract it to a 

location of your choice: 

 
② Next, start up the software. 

③ Open the extracted folder and tap index.html to open the application screen in 

Chrome. Bookmark this page in order to access the software quickly next time 

you wish to use it. 

Studuino:bit StuduinoLite 

Studuino:bit 

https://www.artec-kk.co.jp/artecrobo2/data/chrome.zip 

https://www.artec-kk.co.jp/artecrobo2/data/chrome.zip
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3.3.3. Connecting 
① Connect your Core Unit to the PC using a USB cable. 

 
② Now choose Connect from the Edit Menu. 

 
③ Once connected you’ll see the Sensor Board which will show a live update of the 

Core Unit’s sensors. Disconnecting the USB cable will interrupt the connection 

and the values will no longer update. 
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④ If you want to close the connection, choose the Edit menu before selecting 

Disconnect. If the connection has been interrupted due to an unplugged USB 

cable, choose Disconnect. 

 
 

 

 

3.3.4. Transferring a Program (Robot Mode Only) 
① Choose Transfer from the Edit menu. 

 
② Choose a destination slot to transfer the program to. You can also change the 

name of the program here. 
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③ The blue LED you see below will light up once the transfer starts and turn off to 

indicate that the transfer is successful. 

 
④ If you see a white LED or the blue LED does not turn off, the transfer has failed. 

Press the Reset button and try transferring again. 

 
 

 

3.3.5. Saving and Loading a Project 
The File menu is where you can save and load projects which you’ve made. 

If you want to save a project, choose the File menu and select Save to your 

computer. 

If you want to load a project which has been saved previously, choose the File menu 

and select Load from your computer to choose from a list of files. 
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3.3.6. Loading a Downloaded Project 
Start by downloading a program file from the ArtecRobo 2.0 website. 

● For .sbd Files 

You can load the extracted .sbd file by choosing the File menu and selecting Load 

from your computer. 

 
 

● For .zip Files 

Open the Files app on Chromebook and tap the downloaded .zip file to open it and 

show the .sbd program file. 

 

Drag and drop the .sbd file to My Files or a location of your choice in order to copy 

it. 

 

You can load the .sbd file by choosing the File menu and selecting Load from your 

computer. 
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3.3.7. Updating Firmware 
You’ll need the update the firmware of your Core Unit every time the Studuibo:bit 

Software updates to a new version. When you update your software, you can update 

your firmware either by using the Help menu on your computer or when prompted 

to do so while using the software on a tablet. 

★ When updating firmware your tablet will connect to the Core Unit’s wireless 

access point. 

Please be aware that you won’t be able to update the firmware if your device has 

restrictions on which access points it can connect to. 

 

① Choose the Help menu and select Firmware update. 

 
② A new page will open which will guide you along in updating your firmware. 

③ Check whether the top right LED has lit up in green. 

 
④ The Core Unit will connect to the Chromebook as a wireless access point. 

The Chromebook Wi-Fi settings screen will open to connect to the Core Unit. 

Type 0123456789 into the password box. 

 

⑤ Click the Update button to update the firmware.  
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⑥ The firmware update process will begin. The LEDs in the display will light up in 

white in order. 

 
⑦ The update is complete once every LED has turned on and the display goes dark. 

The firmware update screen will close once the update is complete. 
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3.4. For Mac OS X 
This section details how to setup the Studuino:bit Software on Mac OS X. 

3.4.1. Installation 
Download the installation file before installing the software. If you’re installing the 

software to a PC without an active Internet connection, download the file on a PC 

with an Internet connection before using an external memory device to transfer the 

file to the target PC. 

[1] Download the Software  

① Visit the ArtecRobo 2.0 website at https://www.artec-kk.co.jp/artecrobo2/en/: 

② Once the page opens, click Software Downloads. 

③ Click the Software Download button under Mac OS X to download the file. 

 

[2] Installation 

① Open the downloaded file. 

② This will open a new folder. Move the StuduinoBit.app file inside of this folder to 

your Applications folder. 

 
  

https://www.artec-kk.co.jp/artecrobo2/en/
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[3] Starting the Software 

① Follow the steps below when starting the software for the first time. After 

starting the software, double click StuduinoBit.app. 

1. Hold down the Control key as you click StuduinoBit.app. 

2. Choose Open from the menu. 

3. When you see the confirmation, click Open. 

 

② The software startup screen will allow you to choose the software mode. 

See 5. Switching Between Robot and Character Mode (page 59) to learn the 

difference between software modes. 
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3.4.2. Connecting 
① Connect your Core Unit to the PC using a USB cable. 

 
② Now choose Connect from the Edit Menu. 

 
③ Once connected you’ll see the Sensor Board which will show a live update of the 

Core Unit’s sensors. Disconnecting the USB cable will interrupt the connection 

and the values will no longer update. 
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④ If you want to close the connection, choose the Edit menu before selecting 

Disconnect. If the connection has been interrupted due to an unplugged USB 

cable, choose Disconnect. 

 
 

 

3.4.3. Transferring a Program (Robot Mode Only) 
① Choose Transfer from the Edit menu. 

 
② Choose a destination slot to transfer the program to. You can also change the 

name of the program here. 
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③ The blue LED you see below will light up once the transfer starts and turn off to 

indicate that the transfer is successful. 

 
④ If you see a white LED or the blue LED does not turn off, the transfer has failed. 

Press the Reset button and try transferring again. 

 
 

 

3.4.4. Saving and Loading a Project 
The File menu is where you can save and load projects which you’ve made. 

If you want to save a project, choose the File menu and select Save to your 

computer. 

If you want to load a project which has been saved previously, choose the File menu 

and select Load from your computer to choose from a list of files. 
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3.4.5. Loading a Downloaded Project 
Start by downloading a program file from the ArtecRobo 2.0 website. 

If the file is in a .zip archive, extract the file first. Double click the .zip file to extract 

the .sbd program file. 

You can load the extracted .sbd file by choosing the File menu and selecting Load 

from your computer. 

 
 

 

3.4.6. Updating Firmware 
You’ll need the update the firmware of your Core Unit every time the Studuibo:bit 

Software updates to a new version. When you update your software, you can update 

your firmware either by using the Help menu on your computer or when prompted 

to do so while using the software on a tablet. 

 
When your Core Unit is connected via USB, choose OK to begin updating the 

firmware. 
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3.5. For Android 
Learn how to setup the Studuino:bit Software on Android devices. 

 

★ While you can use this app with Chromebooks sold after 2016 which 

support Android apps and Bluetooth 4.0, using Studuino:bit app with 

Bluetooth may cause instability with certain versions of ChromeOS as of 

September 2020. Please use a wired USB connection for maximum stability. 

 

3.5.1. Installation 
In the Google Play Store, search for Studuino:bit and install the software. 

You’ll see the icon below in your applications once installed. 

 
3.5.2. Connecting 
① Plug the Battery Box into the BATT port on your Core Unit and turn it on. 

 
 

 

 

 

 



Android 
 

41 
 

② Now choose Connect from the Edit Menu. 

 
③ Follow the instructions on the screen and hold down the B button as you press 

the Reset button once. 

  
④ Hold down the B button until you see a colorful LED pattern appear on the 

display. 
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⑤ In the software, choose the device with the same pattern as the Core Unit’s LED 

display. 

 
⑥ Once connected you’ll see the Sensor Board which will show a live update of the 

Core Unit’s sensors. 

  
⑦ If you want to close the connection, choose the Edit menu before selecting 

Disconnect. If the connection has been interrupted, choose Disconnect. 

 
  

Connect 

Choose the Refresh button 
if you don’t see your pattern in the 
software. 
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3.5.4. Transferring a Program (Robot Mode Only) 
① Choose Transfer from the Edit menu. 

 
② Follow the instructions on the screen and hold down the B button as you press 

the Reset button once. 

 
③ Hold down the B button until you see a colorful LED pattern appear on the 

display. 
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④ In the software, choose the device with the same pattern as the Core Unit’s LED 

display. 

 
⑤ Choose a destination slot to transfer the program to. You can also change the 

name of the program here. 

 
  

Connect 

Choose the Refresh button 
if you don’t see your pattern in the 
software. 
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⑦ The blue LED you see below will light up once the transfer starts and turn off to 

indicate that the transfer is successful. 

 
 

⑧ If you see a white LED or the blue LED does not turn off, the transfer has failed. 

Press the Reset button and try transferring again. 
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3.5.6. Saving and Loading a Project 
The File menu is where you can save and load projects which you’ve made. 

 
If you want to save a project, choose the File menu and select Save to your 

computer. 

Type the project name and select OK to save it as a new file. 

Tap a project in the list and that name will appear in the text box. Tap OK to save 

over the existing project. 

 
  

Name your project 

Saved projects are shown here 
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If you want to load a project which has been saved previously, choose the File menu 

and select Load from your computer. Choose a project for the list before tapping 

OK. 
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3.5.7. Loading a Downloaded Project 
Start by downloading a program file from the ArtecRobo 2.0 website. 

 

● For .sbd Files 

Tap Open and a message will appear allowing you to choose an app to open the file. 

Tap Once and you’ll see this message again next time you open the file. Tap Always 

and the Studuino:bit app will automatically open the file next time. 

The file will be saved to your Downloads folder, and you can check it using a file 

manager app. Read the instructions for each app to learn how to best use it. 

 

Choose the File menu and select Save to your computer to save the current 

project. 

 

You can now open the file by choosing the File menu and selecting Load from your 

computer. 
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● For .zip Files 

The file will be saved to your Downloads folder, and you can check it using an app 

like File Manager. Use a decompression app to extract the downloaded .zip file. Open 

the extacted .sbd file using an app like File Manager. Read the instructions for each 

app to learn how to best use it. 

 

Choose the File menu and select Save to your computer to save the current 

project. 

 

You can now open the file by choosing the File menu and selecting Load from your 

computer. 
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3.5.8. Sharing Projects 
If you want to share a project you’ve made, choose the File menu and select Load 

from your computer. Choose a project for the list before tapping Share and 

choosing a sharing method. 
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3.5.9. Updating Firmware 
You’ll need the update the firmware of your Core Unit every time the Studuibo:bit 

Software updates to a new version. When you update your software, you can update 

your firmware either by using the Help menu on your computer or when prompted 

to do so while using the software on a tablet. 

★ When updating firmware your tablet will connect to the Core Unit’s wireless 

access point. 

Please be aware that you won’t be able to update the firmware if your device has 

restrictions on which access points it can connect to. 

 

① Choose the Help menu and select Firmware update. 

 
② Tap OK. 
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③ Check whether the top right LED has lit up in green, then tap OK. 

 
④ The Core Unit will connect to the iPad as a wireless access point. 

 

⑤ The firmware update process will begin. The LEDs in the display will light up in 

white in order. 

 

The update is complete once every LED has turned on and the display goes dark.  
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4. Transferring Data from PC to Tablet 
This section details how to transfer projects from PCs (Windows, Mac OS X) to 

tablets (Android, iPad). 

4.1. Transferring from Windows to Android 
① Make sure that the Studuino:bit Software has been installed on your Windows 

PC and the Studuino:bit app has been installed on your Android tablet. 

② Use a USB cable to connect your tablet to your PC. 

③ A USB charging this device notification will appear on your tablet. 

④ Under your USB configuration choose Transfer files (MTP). 

⑤ Once the file transfer opens on your PC, open the device’s internal storage and 

transfer your project file to the Download folder. 

⑥ Once the file has transferred, disconnect the cable from your PC and unplug the 

USB cable. 

⑦ In the Google Play Store, search for Files by Google and install the software. 

Files by Google is Google’s own file management app. 

⑧ Open Files by Google and tap the Download folder. 

 

⑨ Choose the project you’ve just transferred. 
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⑩ Tap the Share button to open the project file in the Studuino:bit app. 

 
⑪ Choose the File menu and select Save to your computer. You can now open 

the project by choosing the File menu and selecting Load from your 

computer. 
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4.3. Transferring from Windows to iPad 
① Make sure that the Studuino:bit Software has been installed on your Windows 

PC and the Studuino:bit app has been installed on your iPad. 

② Install iTunes for Windows on your PC. 

③ Use a USB cable to connect your tablet to your PC. 

④ Click the devices mark at the top left of the iTunes window. 

 
 

⑤ Click File Sharing and choose Studuino:bit from the list of apps. 

⑥ Drag and drop the project file to transfer it before closing iTunes. 

 
⑦ Unplug your USB cable. 

⑧ You can now open the project by choosing the File menu and selecting Load 

from your computer. 
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4.4. Transferring from Mac OS X to Android 
① Make sure that the Studuino:bit Software has been installed on your Mac and 

the Studuino:bit app has been installed on your Android tablet. 

② Download Android File Transfer to your computer. Android File Transfer is a file 

manager developed by Google which allows you to transfer files from Mac OS X 

to Android devices. 

③ Open the downloaded .dmg file and drag and drop it to your Applications 

folder. 

 
④ Use a USB cable to connect your tablet to your PC. 

⑤ A USB charging this device notification will appear on your tablet. 

⑥ Under your USB configuration choose Transfer files (MTP). 

⑦ Android File Transfer will open once your computer has recognized the Android 

device, allowing you to browse the files on the device.  

 
⑧ Move the project file to the Download folder on the Android device. 
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⑨ Once the file has transferred, disconnect the cable from your PC and unplug the 

USB cable. 

⑩ In the Google Play Store, search for Files by Google and install the software. 

Files by Google is Google’s own file management app. 

⑪ Open Files by Google and tap the Download folder. 

⑫ Choose the project you’ve just transferred. 

  

 

 

 

⑬ Tap the Share button to open the project file in the Studuino:bit app. 

 
⑭ Choose the File menu and select Save to your computer. You can now open 

the project by choosing the File menu and selecting Load from your 

computer. 
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4.5. Transferring from Mac OS X to iPad 
① Make sure that the Studuino:bit Software has been installed on your Mac and 

the Studuino:bit app has been installed on your iPad 

② On your Mac, choose the project file you wish to transfer. 

③ Click the  share button in the app window. You can also hold down the 

control key and click the file in Finder, then choose Share from the shortcut 

menu. 

④ Choose AirDrop from the list of available sharing options. 

⑤ Choose iPad in the AirDrop sheet to transfer the file. 

⑥ Studuino:bit will open automatically once the iPad has received the project file. 

⑦ Choose the File menu and select Save to your computer. You can now open 

the project by choosing the File menu and selecting Load from your 

computer. 
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5. Switching Between Robot and Character Mode 
You can switch between modes by choosing the Edit menu and selecting Switch to 

the character mode or Switch to the robot mode. 

 
● Robot Mode  

Robot mode allows you to make programs which control a robot and transfer the 

programs to your Core Unit. You can also convert any programs you make in this 

mode into the Python programming language. 

 

● Character Mode 

Character mode allows you to make programs using sprites and animate those 

sprites on the screen. 
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6. Troubleshooting 
Follow along below to troubleshoot any issues you may have when using this 

software. If you’re still having trouble or can’t find your issue on the above page, feel 

free to contact us directly using the information in Contact Us on page 64. 

Issue Solution 

The parts I’ve bought are 

missing or broken. 

Please contact us using the information in 

Contact Us on page 64. 

Are there instruction manuals 

for the software? 

You can find manuals which will help you set up 

the software at the URL below: 
https://www.artec-kk.co.jp/artecrobo2/en/software/ 

Please use the in-software tutorials to learn how 

to use the software itself. 

Are there PDFs for the 

projects in my kit? 

 https://www.artec-kk.co.jp/artecrobo2/en/sample/ 

 Follow this link to download building instructions 

for each project. 

My DC Motor is clicking and 

spinning. 

Due to excessive strain, your motor has slipped 

to protect its gears. To prevent damage to the 

internal gears, the motor is designed to emit 

clicks and begin turning freely ("slip") when a 

excessive strain is placed on the axis. Should this 

occur, you will need to inspect your project and 

fix any strain being placed on the gears. The 

wear and tear caused by continuously running a 

motor in this condition reduces the amount of 

strain required for another slip to occur. 

 

  

https://www.artec-kk.co.jp/artecrobo2/ja/software/
https://www.artec-kk.co.jp/artecrobo2/en/sample/


 
 

61 
 

Issue Solution 

The DC Motors won’t move. Your port settings may be incorrect. Check and 

confirm that your Port Settings match the ports 

on your ArtecRobo 2.0 unit and that your 

program is using the correct port numbers. 

Your batteries may be out of power. Try using 

fresh batteries. 

The DC Motors in my project 

start to move erratically. 

Your batteries may be out of power. Once 

batteries are depleted enough, the resulting 

drop in voltage will cause DC Motors to reset 

when they attempt to move (such as rotating or 

changing direction). Try using fresh batteries. 

My Servomotors don’t rotate to 

the angles I set. 

Your batteries may be out of power. Try using 

fresh batteries. 

The particular Servomotor has an error of five 

or more degrees. Use the Motor Calibration 

feature in the software to correct this. 

My Servomotors won’t move. Your batteries may be out of power. Try using 

fresh batteries. 

★ Projects which use multiple Servomotors 

may not move smoothly even when using fresh 

batteries. Always remember to use alkaline 

batteries. 

My Servomotors slip and take a 

while to move again. 

In order to protect the internal gears from 

excessive strain, power to the Servomotor is 

temporarily cut. Inspect your project and fix 

any strain being placed on the gears. 

My sensors aren't reacting. Your port settings may be incorrect. Check and 

confirm that your Port Settings match the ports 

on your ArtecRobo 2.0 unit and that your 

program is using the correct port numbers. 
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Issue Solution 

My devices won’t 

communicate. 

Running multiple programs that use 

inter-device communications at the same time 

may cause interference. Try starting up the 

program on one Core Unit first, then starting 

the program on each subsequent Core Unit you 

intend to communicate with only when the 

previous Unit's program finished its startup. 

I can’t transfer programs. The 

top right LED won’t light up in 

white. 

1. The transfer has failed. Press the Reset 

button and try transferring again. 

2. The transfer may fail due to outdated 

software or firmware. Download the latest 

version of the software and update your 

firmware before trying again. 

The variable, list, or custom 

block I’ve made doesn’t show 

up. 

Switch from the Code tab to another tab such 

as Python before switching back to the Code 

tab. 

My wireless blocks don’t work 

in Test Mode. 

Wireless blocks will only work when the 

program has been transferred. 

 

My Core Unit keeps 

disconnecting (Windows, Mac 

OS X) 

Your USB cable or Core Unit connector may be 

damaged.  

Try replacing the USB cable. If the issue 

continues, contact us using the information in 

Contact Us on page 64. 

My Core Unit keeps 

disconnecting (iOS, Android) 

Your batteries may be out of power. Try 

replacing them with fresh batteries. 
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Issue Solution 

The top right LED lights up in 

green when I turn on the Core 

Unit (iOS, Android, 

Chromebook) 

The Unit is connected to WiFi and is awaiting a 

firmware update. 

Choose the Help menu and select Firmware 

update to finish the update. 

If you won’t wish to update the firmware, hold 

down the A button and press the Reset button 

or wait 1-2 minutes for the LED to turn off and 

the Core Unit to exit standby mode. 

I updated by firmware and now 

get an error when I try to 

connect. 

Once the firmware is updated, press the Reset 

button on the Core Unit to check if the green 

LED below the button lights up before 

connecting again. 

I’ve tried multiple times to 

update my firmware but it 

doesn’t work. 

Your USB cable or Core Unit connector may be 

damaged. 

Try replacing the USB cable. If the issue 

continues, contact us using the information in 

Contact Us on page 64. 

I transferred my program but it 

doesn’t work correctly. 

Make sure the numbers in your program are 

correct. Using incorrect numbers in blocks 

which use numerical values can cause your 

project to work in unexpected ways. 

I get a message stating that my 

Core Unit’s firmware can’t be 

updated. 

Your firmware may be outdated or your device 

may not be able to update the device over WiFi. 

Open the software on a PC and use the Help 

menu to update the firmware. If you don’t own 

a PC, please contact us using the information in 

Contact Us on page 64. 
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Issue Solution 

I get a message saying 

my device can’t be found 

when attempting to 

connect to it. 

Device drivers must be installed on Windows 7 and 

Windows 8.1 systems. Follow the URL below to 

download the device driver before installing it on your 

system: 

https://www.artec-kk.co.jp/artecrobo2/en/software/ 

★ Administrator privileges are required to install the 

software. 

I don’t see my Core Unit’s 

pattern on the device 

selection screen (iOS, 

Android, Chromebook) 

1. The device may have not been found during the 

search. Choose Refresh to search for the device 

again. 

2. Turn your tablet’s Bluetooth off before turning it on 

again. 

I can’t find the Join a 

Network option in the 

Edit menu (iOS, Android, 

Chromebook) 

Network is only available via a USB connection on a 

Windows or Mac OS X device. 

 

 

 

7. Contact Us 

Artec Co., Ltd. Customer Support Desk 

E-mail: support@artec-kk.co.jp 

https://www.artec-kk.co.jp/artecrobo2/ja/software/
mailto:support@artec-kk.co.jp
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